3

USN-904-1: Squid vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2010-0639 Description:  =========================================================== Ubuntu Security Notice USN-904-1 February 24, 2010 squid vulnerability CVE-2010-0639 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.04 LTS: squid 2.6.18-1ubuntu3.2 Ubuntu 8.10: squid 2.7.STABLE3-1ubuntu2.3 Ubuntu 9.04: squid 2.7.STABLE3-4.1ubuntu1.2 Ubuntu 9.10: squid 2.7.STABLE6-2ubuntu2.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that Squid incorrectly handled certain malformed packets received on the HTCP port. A remote attacker could exploit this with a specially-crafted packet and cause Squid to crash, resulting in a denial of service. (Distributions)