6

USN-900-1: Ruby vulnerabilities

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-1904, CVE-2009-4124, CVE-2009-4492 Description:  =========================================================== Ubuntu Security Notice USN-900-1 February 16, 2010 ruby1.9 vulnerabilities CVE-2009-1904, CVE-2009-4124, CVE-2009-4492 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.10: libruby1.9 1.9.0.2-7ubuntu1.3 ruby1.9 1.9.0.2-7ubuntu1.3 Ubuntu 9.04: libruby1.9 1.9.0.2-9ubuntu1.2 ruby1.9 1.9.0.2-9ubuntu1.2 Ubuntu 9.10: libruby1.9 1.9.0.5-1ubuntu1.2 ruby1.9 1.9.0.5-1ubuntu1.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Emmanouel Kellinis discovered that Ruby did not properly handle certain string operations. An attacker could exploit this issue and possibly execute arbitrary code with application privileges. (CVE-2009-4124) Giovanni Pellerano, Alessandro Tanasi, and Francesco Ongaro discovered that Ruby did not properly sanitize data written to log files. An attacker could insert specially-crafted data into log files which could affect certain terminal emulators and cause arbitrary files to be overwritten, or even possibly execute arbitrary commands. (CVE-2009-4492) It was discovered that Ruby did not properly handle string arguments that represent large numbers. An attacker could exploit this and cause a denial of service. This issue only affected Ubuntu 9.10. (CVE-2009-1904) (Distributions)