4

USN-892-1: FUSE vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-3297 Description:  =========================================================== Ubuntu Security Notice USN-892-1 January 28, 2010 fuse vulnerability CVE-2009-3297 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: fuse-utils 2.4.2-0ubuntu3.1 Ubuntu 8.04 LTS: fuse-utils 2.7.2-1ubuntu2.1 Ubuntu 8.10: fuse-utils 2.7.3-4ubuntu2.1 Ubuntu 9.04: fuse-utils 2.7.4-1.1ubuntu4.0.9.04.1 Ubuntu 9.10: fuse-utils 2.7.4-1.1ubuntu4.3 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Dan Rosenberg discovered that FUSE did not correctly check mount locations. A local attacker, with access to use FUSE, could unmount arbitrary locations, leading to a denial of service. (Distributions)