5

USN-887-1: LibThai vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-4012 Description:  =========================================================== Ubuntu Security Notice USN-887-1 January 18, 2010 libthai vulnerability CVE-2009-4012 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.04 LTS: libthai0 0.1.9-1ubuntu0.2 Ubuntu 8.10: libthai0 0.1.9-4ubuntu0.8.10.2 Ubuntu 9.04: libthai0 0.1.9-4ubuntu0.9.04.2 Ubuntu 9.10: libthai0 0.1.12-1ubuntu0.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Tim Starling discovered that LibThai did not correctly handle long strings. A remote attacker could use specially-formed strings to execute arbitrary code with the user's privileges. (Distributions)