5

USN-881-1: Kerberos vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-4212 Description:  =========================================================== Ubuntu Security Notice USN-881-1 January 12, 2010 krb5 vulnerability CVE-2009-4212 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libkrb53 1.4.3-5ubuntu0.10 Ubuntu 8.04 LTS: libkrb53 1.6.dfsg.3~beta1-2ubuntu1.3 Ubuntu 8.10: libkrb53 1.6.dfsg.4~beta1-3ubuntu0.3 Ubuntu 9.04: libkrb53 1.6.dfsg.4~beta1-5ubuntu2.2 Ubuntu 9.10: libk5crypto3 1.7dfsg~beta3-1ubuntu0.3 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that Kerberos did not correctly handle invalid AES blocks. An unauthenticated remote attacker could send specially crafted traffic that would crash the KDC service, leading to a denial of service, or possibly execute arbitrary code with root privileges. (Distributions)