4

USN-880-1: GIMP vulnerabilities

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-1570, CVE-2009-3909 Description:  =========================================================== Ubuntu Security Notice USN-880-1 January 07, 2010 gimp vulnerabilities CVE-2009-1570, CVE-2009-3909 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.04 LTS: gimp 2.4.5-1ubuntu2.1 Ubuntu 8.10: gimp 2.6.1-1ubuntu3.1 Ubuntu 9.04: gimp 2.6.6-0ubuntu1.1 Ubuntu 9.10: gimp 2.6.7-1ubuntu1.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Stefan Cornelius discovered that GIMP did not correctly handle certain malformed BMP files. If a user were tricked into opening a specially crafted BMP file, an attacker could execute arbitrary code with the user's privileges. (CVE-2009-1570) Stefan Cornelius discovered that GIMP did not correctly handle certain malformed PSD files. If a user were tricked into opening a specially crafted PSD file, an attacker could execute arbitrary code with the user's privileges. This issue only applied to Ubuntu 8.10, 9.04 and 9.10. (CVE-2009-3909) (Distributions)