3

USN-876-1: PostgreSQL vulnerabilities

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-4034, CVE-2009-4136 Description:  =========================================================== Ubuntu Security Notice USN-876-1 January 03, 2010 postgresql-8.1, postgresql-8.3, postgresql-8.4 vulnerabilities CVE-2009-4034, CVE-2009-4136 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: postgresql-8.1 8.1.19-0ubuntu0.6.06 Ubuntu 8.04 LTS: postgresql-8.3 8.3.9-0ubuntu8.04 Ubuntu 8.10: postgresql-8.3 8.3.9-0ubuntu8.10 Ubuntu 9.04: postgresql-8.3 8.3.9-0ubuntu9.04 Ubuntu 9.10: postgresql-8.4 8.4.2-0ubuntu9.10 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that PostgreSQL did not properly handle certificates with NULL characters in the Common Name field of X.509 certificates. An attacker could exploit this to perform a man in the middle attack to view sensitive information or alter encrypted communications. (CVE-2009-4034) It was discovered that PostgreSQL did not properly manage session-local state. A remote authenticated user could exploit this to escalate priviliges within PostgreSQL. (CVE-2009-4136) (Distributions)