3

USN-872-1: KDE 4 Runtime vulnerabilities

view full story
linux-howto

http://www.ubuntu.com – Description:  =========================================================== Ubuntu Security Notice USN-872-1 December 11, 2009 kdebase-runtime vulnerabilities https://launchpad.net/bugs/495301 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.10: kdebase-runtime 4:4.1.4-0ubuntu1~intrepid1.2 Ubuntu 9.04: kdebase-runtime 4:4.2.2-0ubuntu1.1 Ubuntu 9.10: kdebase-runtime 4:4.3.2-0ubuntu4.1 After a standard system upgrade you need to restart your session to effect the necessary changes. Details follow: It was discovered that the KIO subsystem of KDE did not properly perform input validation when processing help:// URIs. If a user or KIO application processed a crafted help:// URI, an attacker could trigger JavaScript execution or access files via directory traversal. (Distributions)