4

USN-842-1: Wget vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-3490 Description:  =========================================================== Ubuntu Security Notice USN-842-1 October 06, 2009 wget vulnerability CVE-2009-3490 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: wget 1.10.2-1ubuntu1.1 Ubuntu 8.04 LTS: wget 1.10.2-3ubuntu1.1 Ubuntu 8.10: wget 1.11.4-1ubuntu1.1 Ubuntu 9.04: wget 1.11.4-2ubuntu1.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that Wget did not correctly handle SSL certificates with zero bytes in the Common Name. A remote attacker could exploit this to perform a man in the middle attack to view sensitive information or alter encrypted communications. (Distributions)