3

USN-818-1: curl vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-2417 Description:  =========================================================== Ubuntu Security Notice USN-818-1 August 17, 2009 curl vulnerability CVE-2009-2417 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: libcurl3 7.15.1-1ubuntu3.2 Ubuntu 8.04 LTS: libcurl3 7.18.0-1ubuntu2.2 Ubuntu 8.10: libcurl3 7.18.2-1ubuntu4.4 Ubuntu 9.04: libcurl3 7.18.2-8ubuntu4.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Scott Cantor discovered that Curl did not correctly handle SSL certificates with zero bytes in the Common Name. A remote attacker could exploit this to perform a man in the middle attack to view sensitive information or alter encrypted communications. (Distributions)