4

USN-804-1: PulseAudio vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-1894 Description:  =========================================================== Ubuntu Security Notice USN-804-1 July 16, 2009 pulseaudio vulnerability CVE-2009-1894 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 8.04 LTS: pulseaudio 0.9.10-1ubuntu1.1 Ubuntu 8.10: pulseaudio 0.9.10-2ubuntu9.4 Ubuntu 9.04: pulseaudio 1:0.9.14-0ubuntu20.2 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Tavis Ormandy and Yorick Koster discovered that PulseAudio did not safely re-execute itself. A local attacker could exploit this to gain root privileges. (Distributions)