6

USN-789-1: GStreamer Good Plugins vulnerability

view full story
linux-howto

http://www.ubuntu.com – Referenced CVEs:  CVE-2009-1932 Description:  =========================================================== Ubuntu Security Notice USN-789-1 June 22, 2009 gst-plugins-good0.10 vulnerability CVE-2009-1932 =========================================================== A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: gstreamer0.10-plugins-good 0.10.3-0ubuntu4.2 Ubuntu 8.04 LTS: gstreamer0.10-plugins-good 0.10.7-3ubuntu0.3 Ubuntu 8.10: gstreamer0.10-plugins-good 0.10.10.4-1ubuntu1.2 Ubuntu 9.04: gstreamer0.10-plugins-good 0.10.14-1ubuntu0.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: Tielei Wang discovered that GStreamer Good Plugins did not correctly handle malformed PNG image files. If a user were tricked into opening a crafted PNG image file with a GStreamer application, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program. (Distributions)