5

Upgrade from F9 to F11 using preupgrade-cli

view full story
linux-howto

http://forums.fedoraforum.org – Hi all, I went to upgrade my daughters machine that was running F9 using preupgrade-cli after having issues with mirrors timing out it finally completed the first part with the notification install will start once you reboot. so I rebooted the machine and when it rebooted the grub menu came up with the F9 install selected but with an option for the F11 Upgrade I choose the upgrade and it starts and I see the installation screen with the stop watch and all of a sudden the comp restarts now at the grub menu again and there is no option for F11 upgrade so I boot into F9 try to run it again and it throws a bunch of errors about the rpm database... Encountering this before i run rm -f /var/lib/rpm/__db* rpm -vv --rebuilddb yum clean all but yum just blows errors now and if I run rpm -qa it returns nothing. Is there any recovering from this? or should I back up the home dirs and do a fresh install? this is the output of the rebuild Code: D: rebuilding database /var/lib/rpm into /var/lib/rpmrebuilddb.2367 D: creating directory /var/lib/rpmrebuilddb.2367 D: opening old database with dbapi 3 D: opening  db environment /var/lib/rpm/Packages create:cdb:mpool D: opening  db index      /var/lib/rpm/Packages rdonly mode=0x0 D: locked  db index      /var/lib/rpm/Packages D: opening new database with dbapi 3 D: opening  db environment /var/lib/rpmrebuilddb.2367/Packages create:mpool D: opening  db index      /var/lib/rpmrebuilddb.2367/Packages create mode=0x42 D: closed  db index      /var/lib/rpm/Packages D: closed  db environment /var/lib/rpm/Packages D: closed  db index      /var/lib/rpmrebuilddb.2367/Packages D: closed  db environment /var/lib/rpmrebuilddb.2367/Packages D: removing directory /var/lib/rpmrebuilddb.2367 D: May free Score board((nil)) this is the error for yum clean all after the rebuild completes successfully Code: Loaded plugins: fastestmirror, refresh-packagekit rpmdb: PANIC: fatal region error detected; run recovery error: db4 error(-30977) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery error: cannot open Packages index using db3 -  (-30977) error: cannot open Packages database in /var/lib/rpm Traceback (most recent call last):   File "/usr/bin/yum", line 29, in <module>     yummain.user_main(sys.argv[1:], exit_code=True)   File "/usr/share/yum-cli/yummain.py", line 229, in user_main     errcode = main(args)   File "/usr/share/yum-cli/yummain.py", line 84, in main     base.getOptionsConfig(args)   File "/usr/share/yum-cli/cli.py", line 184, in getOptionsConfig     enabled_plugins=self.optparser._splitArg(opts.enableplugins))   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 192, in _getConfig     self._conf = config.readMainConfig(startupconf)   File "/usr/lib/python2.5/site-packages/yum/config.py", line 774, in readMainConfig     yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)   File "/usr/lib/python2.5/site-packages/yum/config.py", line 844, in _getsysver     idx = ts.dbMatch('provides', distroverpkg) TypeError: rpmdb open failed (HowTos)