4

[ubuntu] Cannot display video on my graphics card

view full story
linux-howto

http://ubuntuforums.org – I'm running ubuntu 904 and using a SIS chipset video card 'sitecom cn-105'. It's working but I cannot play videos on that monitor. I've tried using mplayer and mira with no luck. On the Nvidia monitors I can play video. So I'm assuming it's some option I'm missing in my SIS device section. I've tried enabling DRI for that and it didn't help. Here is my xorg.conf: Code: # xorg.conf (X.Org X Window System server configuration file) # # This file was generated by dexconf, the Debian X Configuration tool, using # values from the debconf database. # # Edit this file with caution, and see the xorg.conf manual page. # (Type "man xorg.conf" at the shell prompt.) # # This file is automatically updated on xserver-xorg package upgrades *only* # if it has not been modified since the last upgrade of the xserver-xorg # package. # # If you have edited this file but would like it to be automatically updated # again, run the following command: #  sudo dpkg-reconfigure -phigh xserver-xorg # commented out by update-manager, HAL is now used #Section "InputDevice" #        Identifier        "Generic Keyboard" #        Driver                "kbd" #        Option                "XkbRules"        "xorg" #        Option                "XkbModel"        "pc105" #        Option                "XkbLayout"        "us" #EndSection # commented out by update-manager, HAL is now used #Section "InputDevice" #        Identifier        "Configured Mouse" #        Driver                "mouse" #        Option                "CorePointer" #EndSection Section "Device"         Identifier        "Nvidia[0]" #        Option "TwinView" "True" #        Option "TwinViewOrientation" "RightOf" #        Option "TwinViewXineramaInfoOrder" "DFP" #        Option "MetaModes" "1600x1024 1280x1024"         Driver                "nvidia"         VendorName            "NVIDIA Corporation"         BoardName              "GeForce 9400 GT"         Screen                0         BusID                "PCI:1:0:0         Option          "RenderAccel"  "true"         Option          "UseEdidFreqs"  "true"         Option                "NoLogo"        "True" EndSection Section "Device"         Identifier        "Nvidia[1]"         Driver                "nvidia"         VendorName            "NVIDIA Corporation"         BoardName        "GeForce 9400 GT"         Screen                1         BusID                "PCI:1:0:0         Option          "RenderAccel"  "true"         Option          "UseEdidFreqs"  "true"         Option                "NoLogo"        "True" EndSection Section "Device"         Identifier "SiS[0]"         VendorName "SiS" # Value does not matter         BoardName "SiS" # Value does not matter         Driver "sisusb"         #Option "DRI" "true" # This does not help video EndSection Section "Monitor"     # HorizSync source: edid, VertRefresh source: edid     Identifier    "Nvidia-Monitor[0]"     VendorName    "Unknown"     ModelName      "BENQ E2400HD"     HorizSync      30.0 - 83.0     VertRefresh    55.0 - 85.0     Option        "DPMS" EndSection Section "Monitor"     # HorizSync source: edid, VertRefresh source: edid     Identifier    "Nvidia-Monitor[1]"     VendorName    "Unknown"     ModelName      "MEA DV173B"     HorizSync      30.0 - 82.0     VertRefresh    50.0 - 75.0     Option        "DPMS" EndSection Section "Monitor"         Identifier "SiS-Monitor[0]" #SISUSBVGA         VendorName "Monitor Vendor" # value does not matter         ModelName "Monitor Model" # value does not matter         VertRefresh 50-75         HorizSync 30-90 EndSection Section "Screen"         Identifier        "Nvidia-Screen[0]"         Monitor                "Nvidia-Monitor[0]"         Device                "Nvidia[0]"         Option          "TwinView" "0"         Option          "metamodes" "DFP: nvidia-auto-select +0+0"         DefaultDepth        24 EndSection Section "Screen"         Identifier        "Nvidia-Screen[1]"         Monitor                "Nvidia-Monitor[1]"         Device                "Nvidia[1]"         Option          "TwinView" "0"         Option          "metamodes" "DFP: nvidia-auto-select +0+0"         DefaultDepth        24 EndSection Section "Screen"         Identifier "SiS-Screen[0]"         Device "SiS[0]"         Monitor "SiS-Monitor[0]"         DefaultDepth 24         SubSection "Display"                 Depth 16                 Modes "1024x768" "800x600" "640x480"         EndSubSection         SubSection "Display"                 Depth 8                 Modes "1024x768" "800x600" "640x480"         EndSubSection         SubSection "Display"                 Depth 24                 Modes "1024x768" "800x600" "640x480"         EndSubSection EndSection Section "Module"     Load          "dbe"     Load          "extmod"     Load          "type1"     Load          "freetype"     Load          "glx" EndSection Section "ServerLayout"         Identifier        "Default Layout"         screen 0 "Nvidia-Screen[0]"         screen 1 "Nvidia-Screen[1]" LeftOf "Nvidia-Screen[0]"         screen 2 "SiS-Screen[0]" RightOf "Nvidia-Screen[0]" EndSection Section "ServerFlags"         Option  "Xinerama" "1"         Option        "DontZap"        "False" EndSection Section "DRI"         Mode 0666 EndSection (Hardware)