[ubuntu] 2 NICs with same MAC address problem

view full story

http://ubuntuforums.org – Hi All, I have 2 NICs in my U9.04 Server box (eth0, eth1). After I added 2 virtual interfaces for each physical interface (eth0:1,eth0:2,eth1:1,eth1:2), the MAC addresses of all the interfaces have changed to that of eth0. Because eth1 was configured to be on my local network, I can't access the box remotely anymore. Even after I added the MAC addresses to the /etc/network/interfaces file, it still shows only 1 MAC address for all interfaces. This is the configuration Code: # The loopback network interface auto lo iface lo inet loopback # The primary network interface iface eth0 inet static         address         hwaddress ether aa:00:04:00:0a:04         netmask         gateway iface eth0:1 inet static         address         netmask         gateway iface eth0:2 inet static         address         netmask         gateway # The additional network interface auto eth1 iface eth1 inet static         address         hwaddress ether 00:30:bd:b9:f6:81         netmask auto eth1:1 iface eth1:1 inet static         address         netmask auto eth1:2 iface eth1:2 inet static         address         netmask Did my second NIC (eth1) suddenly give in? Can someone please explain what is happening here. Thank you mdewet EDIT: I found that the reason for not being able to connect was actually because the IP address for eth1 also wasn't configured at start-up, even though it is in the configuration file. (HowTos)