2

Trust WB-3100P webcam cannot get it to work

view story
linux-howto

http://forums.fedoraforum.org – I have been trying to get my webcam to work. The built in microphone works fine but no video. I have trawled various forums and Google and tried just about everything suggested. I am running 2.6.31.12-174.2.22.fc12.x86_64 I have listed below various outputs. Does the fact that dmesg shows the camera controller detected as SN9C103 and later shows usbcore registering the interface driver as sn9c102 have any bearing? One forum suggested downloading the 32 bit driver as skype was 32 bit but that didn't work either. Anyone got any further suggestions or do I just accept that this particular camera is not going to work. The v4l2 tool doesn't find a driver but http://moinejf.free.fr/webcam.html lists it as not tested (see below). Selected output from dmesg sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49 usb 2-1: SN9C103 PC Camera Controller detected (vid:pid 0x0C45:0x60AF) . . usb 2-1: PAS202BCB image sensor detected . . usb 2-1: Initialization succeeded usb 2-1: V4L2 device registered as /dev/video0 usb 2-1: Optional device control through 'sysfs' interface disabled usbcore: registered new interface driver sn9c102 . . usb 2-1: usb_submit_urb() failed, error -28 ohci_hcd 0000:00:0b.0: leak ed ffff88003780c0f0 (#81) state 2 usb 2-1: usb_submit_urb() failed, error -28 ohci_hcd 0000:00:0b.0: leak ed ffff88003780c140 (#81) state 2 usb 2-1: usb_submit_urb() failed, error -28 ohci_hcd 0000:00:0b.0: leak ed ffff88003780c190 (#81) state 2 usb 2-1: usb_submit_urb() failed, error -28 ohci_hcd 0000:00:0b.0: leak ed ffff88003780c1e0 (#81) state 2 output from lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 003: ID 046d:c50e Logitech, Inc. MX-1000 Cordless Mouse Receiver Bus 002 Device 002: ID 0c45:60af Microdia VideoCAM Look Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Information from http://moinejf.free.fr/webcam.html shows my camera as not tested but another with the same subdriver and sensor as OK Subdriver Id Name Sensor Status sonixb 0c45:6028 Sonix Btc Pc380 pas202 OK sonixb 0c45:60af Trust WB-3100P pas202 not tested The Id and sensor match with the output from dmesg One suggestion was to preload the libraries [root@FSLServer ~]# LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so camorama [root@FSLServer ~]# LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so camorama [root@FSLServer ~]# camorama all the above resulted in this error message Could not connect to video device (/dev/video0). Please check connection Trying the 32 bit versions [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so camorama [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so camorama resulted in the same error message Trying with Chesee [root@FSLServer ~]# LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so cheese ** (cheese:3835): WARNING **: Failed to open /dev/video0: No space left on device [root@FSLServer ~]# LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so cheese ** (cheese:3844): WARNING **: Failed to open /dev/video0: No space left on device [root@FSLServer ~]# cheese ** (cheese:5263): WARNING **: Failed to open /dev/video0: No space left on device Tried the 32 bit versions as suggested on a forum [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so skype ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored. [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so skype ERROR: ld.so: object '/usr/local/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored. [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so skype ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored. [root@FSLServer ~]# LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so skype ERROR: ld.so: object '/usr/local/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored. The same error was reported using the 64 bit versions. (HowTos)