1

Support Suntrust App

view story
linux-howto

http://androidforums.com – I have a Samsung Galaxy Precedent from Straight Talk. I like the phone, it does what I need it to do. A few months ago I downloaded the Suntrust Mobile App. It works great!! Well, Suntrust has a new app that does more stuff. So I went to download it, and it says my device is not compatible. Suntrust says all Android devices 1.6 or above will work. Well my ph is 2.2.2. I did some reading and thought maybe if I "Root" my ph I could get the app. Well I "rooted" my ph this morning. Downloaded the "Root Checker" and it says my ph is now rooted. I went back to get the (General)