3

ssh Connection closed by .....

view full story
linux-howto

http://www.linuxquestions.org – Hello, I have a ssh problem. Just started the morning as I stat up my machines this morning. All worked well yesterday. ssh from desktop to laptop Desktop Code: Distributor ID: Ubuntu Description:    Ubuntu 7.10 Release:        7.10 Codename:      gutsy Laptop Code: Distributor ID: Ubuntu Description:    Ubuntu 9.10 Release:        9.10 Codename:      karmic I try sshing from desktop to laptop Code: tommy@bodger1:~/marketstall$ ssh -Yv [email protected] OpenSSH_4.6p1 Debian-5build1, OpenSSL 0.9.8e 23 Feb 2007 debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1: Connecting to 10.0.0.12 [10.0.0.12] port 22. debug1: Connection established. debug1: identity file /home/tommy/.ssh/identity type -1 debug1: identity file /home/tommy/.ssh/id_rsa type -1 debug1: identity file /home/tommy/.ssh/id_dsa type -1 debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-6ubuntu2 debug1: match: OpenSSH_5.1p1 Debian-6ubuntu2 pat OpenSSH* debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_4.6p1 Debian-5build1 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-cbc hmac-md5 none debug1: kex: client->server aes128-cbc hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY debug1: Host '10.0.0.12' is known and matches the RSA host key. debug1: Found key in /home/tommy/.ssh/known_hosts:1 debug1: ssh_rsa_verify: signature correct debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug1: SSH2_MSG_NEWKEYS received debug1: SSH2_MSG_SERVICE_REQUEST sent debug1: SSH2_MSG_SERVICE_ACCEPT received Connection closed by 10.0.0.12 so there appears to be an initial connection is made. If I try and ssh onto localhost on the laptop I get the same issue. So I can't even ssh within the machine! I've tried restarting ssh, I've tried restating my router, I've tried restarting my laptop. No luck. I've looked at this thread http://www.linuxquestions.org/questi...e-host-267052/ but it appear to be no help. That persons computer does not seem to make a connection like mine does. However I've still gone through the thread. I've looked in /proc/sys/net/core/netdev_max_backlog and changed that from 1000 to 1001 I've looked in /proc/sys/net/core/somaxconn and changed that from 128 to 129 /etc/hosts.deny is all commented out /etc/hosts.allow I've added my desktop i.p address. No luck can someone please give me some help I have no idea on these issues. (HowTos)