5

[Solved] failed to commit transaction (invalid or corrupted package)

view full story
linux-howto

https://bbs.archlinux.org – I hadn't upgraded in awhile due to internet download limitations.  I go to upgrade today and there were 120 packages to upgrade.  Couldn't get anywhere.  Kept getting: "error: failed to commit transaction (invalid or corrupted package)"Google to the rescue...https://bugs.archlinux.org/task/29585[root@(none) ~]# cd /var/cache/pacman/pkg [root@(none) pkg]# ls *.part filesystem-2012.6-4-any.pkg.tar.xz.part [root@(none) pkg]# rm *.part [root@(none) pkg]# pacman -SyuSUCCESS! David Batson https://bbs.archlinux.org/profile.php?id=53236 2012-07-11T04:55 (HowTos)