For Debian, I'd like to block packages from installation. For instance, I'd like puppet and superusers to be unable to install ruby1.8, even if a package with ruby1.8 in its dependency list is requested for installation: the puppet run would fail and so too would
apt-get install ruby1.9.3 installs 1.8.7 as specified by ruby --version
apt-get install ruby/trusty is held back with:
ruby : Depends: ruby1.9.1 (>= 188.8.131.52-1) but 184.108.40.206-1ubuntu2.8 is to be installed
So I'm trying to install this gem but hitting an error. https://github.com/cgore/ruby-btce The actual README says to do a gem install, so I guess I didn't need to clone the git repo? Anyway, I had to install Ruby before doing this and that's all I've installed so far, so I guess I may be missing some other dependencies to install this gem?