14

rpmbuild failed on dependency gnutls-devel even when pkg-config identifies the installed library

view full story
linux-howto

http://serverfault.com – I'm trying to install the latest version of csync2, file synchronization tool, from LINBIT on CENT OS 5.4. Some recent changes made to this software have mandated that gnutls>=2.6 is installed on the system (for SSL support). Unfortunately, the gnutls rpms available on CENT OS 5 are of the version not higher than 1.4.3. However, i found some compat-gnutls*.rpm, compat-gnutls-devel*.rpm from 'art' repository and installed those on my CENT OS 5 system. I verified that this library (names, gnutls) is installed properly by running the following commands which all returned expected results. pkg-c (HowTos)