7

RPM ignoring Requires version

view full story
linux-howto

http://serverfault.com – I've packaged up clamav into some rpms for distribution inside our rhn, however I'm having some issues with dependency resolution when doing upgrades. the spec file builds 4 packages: clamav - contains the main files clamav-db - contains the virus definition files libclamav - contains the clamav libs libclamav-devel - contains devel files I need clamav to require that the libclamav installed is the same version and release as itself. eg clamav-0.96.3-9 should require libclamav-0.96.3-9 however the clamav-db can be any version ( it gets updated with freshcla (HowTos)