4

Onboard audio not working on Asus K8U-X

view full story
linux-howto

http://forums.opensuse.org – Hi. I switched from Kubuntu to SUSE to check if this is a (K)ubuntu only problem. Seems not to be because sound doesn't work with SUSE either. Everybody seems have this same problem with this motherboard + Linux (expect that this mobo seemed to work with some older distributions). I Googled and found out that passing the buggy_semaphore 1 option to the driver module should work. It didn't. Some people got sound output from the microphone jack. I didn't. I Googled more and more and tried basically everything with Kubuntu. I gave up. Few months later I decided to try again with SUSE and here I am. I have tried the same things with SUSE what I did with Kubuntu with no results. I appreciate all help. By the way, could the sounds work with the x86 version? Any ideas? I haven't tried that because I don't want to reinstall the system for nothing if audio ceases to work even with the x86 version. Alsa troubleshooting script URL: http://www.alsa-project.org/db/?f=49...12a476686a2b23 And here's some output: Code: xtrakt@adsl-77-109-220-17:~> cat /proc/asound/version Advanced Linux Sound Architecture Driver Version 1.0.20. Code: xtrakt@adsl-77-109-220-17:~> cat /proc/asound/modules  0 snd_intel8x0 Code: xtrakt@adsl-77-109-220-17:~> cat /proc/asound/cards  0 [M5455          ]: ICH - ALi M5455                       ALi M5455 with AD1888 at irq 18 (Distributions)