0

nokogiri require only works in super user mode

view story
linux-howto

http://stackoverflow.com – I keep on getting an error when I run a file called wc.rb. I type ruby wc.rb but I keep on getting this error /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- nokogiri (LoadError) from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require' from wc.rb:3:in `<main>' however when I run the same script with sudo ruby wc.rb Is there anything I can do so that I don't have to run this script as a super user? (HowTos)