6

No luck with radeon 4670 ati driver, graphics card recommendation?

view full story
linux-howto

http://forums.opensuse.org – Hi, I recently bought a HIS HD 4670 IceQ card but can't get it to work in openSUSE 11.2 Under Windows the card works fine, so I assume there is no hardware problem. I tried this card in two computers with different mainboards, but it does not work. Several times I reinstalled openSUSE completely from scratch (tried both 32bit and 64bit versions) but no luck. The problem: Right after the installation it uses the radeonhd driver. This basically works, but without 3D (no Tuxracer...) and even 2D is slow (dragging around windows on the desktop is slow, page scrolling in firefox also). Then I tried to install the ati proprietary driver, both from rpm (the rpm's from the "official" ati repository have a checksum error, as already mentioned in another thread!), and by downloading the driver from AMD and running the install script. The install script seems to work successfully. The kernel module is compiled and loaded. "aticonfig --initial" makes a rudimentary xorg.conf. But then, when starting X, it does not work: - on one of the 2 tested systems, even kdm does not start, the screen simply stays black with a frozen cursor top left, even CTRL+ALT+backspace doesn't do anything - on the other system, kdm starts and shows the login screen, but when trying to start KDE kwin crashes, and the windows have no title bar (when I googled for this symptome I found lots of people also having this problem...) - trying to configure the system using sax2 didn't help, even sax2 doesn't display properly I have now spent 4 days trying to get this to work and now I'm really tired of those buggy graphics drivers, be it proprietary or open source... Can anyone recommend me a graphics card that is approximately as powerful as the radeon 4670 (I bought this card because it is said to be the most economical card (both in price and energy consumption) that allows to play Anno 1404 reasonably well on windows), but is known to work in openSUSE 11.2, even in 3D mode (tuxracer...)? Thanks, xpuc (Distributions)