4

No CPU Scaling on Fedora 12 KDE

view full story
linux-howto

http://forums.fedoraforum.org – I have a HP laptop (dv6535ep) and I can't seem to enable CPU scaling on fedora 12. Honestly I haven't tried with gnome, but using KDE4 I found that PowerDevil doesn't detect the cpu scaling abilities... My CPU is a AMD Turion and all the correct kernel modules are loaded: cpufreq_ondemand cpufreq_powersave cpufreq_conservative powernow_k8 freq_table and the cpuspeed service is fully loaded! here is my lsmod output: Code: Module                  Size  Used by usb_storage            60592  0 cpufreq_ondemand        7824  1 cpufreq_conservative    8112  0 cpufreq_powersave      2016  0 fuse                  62064  2 nfsd                  278096  9 lockd                  71572  1 nfsd nfs_acl                3152  1 nfsd auth_rpcgss            41456  1 nfsd exportfs                4544  1 nfsd sunrpc                191864  11 nfsd,lockd,nfs_acl,auth_rpcgss nf_conntrack_netbios_ns    2848  0 ip6t_REJECT            5856  2 nf_conntrack_ipv6      21880  11 ip6table_filter        4016  1 ip6_tables            19664  1 ip6table_filter ipv6                  298864  28 ip6t_REJECT,nf_conntrack_ipv6 powernow_k8            17332  1 freq_table              4864  2 cpufreq_ondemand,powernow_k8 dm_multipath          17304  0 uinput                  9248  0 snd_hda_codec_conexant    32592  1 nvidia              9614296  41 snd_hda_intel          30344  4 arc4                    2160  2 uvcvideo              58972  0 videodev              36160  1 uvcvideo snd_hda_codec          72832  2 snd_hda_codec_conexant,snd_hda_intel snd_hwdep              9224  1 snd_hda_codec ecb                    3264  2 b43                  127432  0 sdhci_pci              9008  0 snd_seq                58080  0 mac80211              181496  1 b43 snd_seq_device          7620  1 snd_seq v4l1_compat            14052  2 uvcvideo,videodev snd_pcm                83144  3 snd_hda_intel,snd_hda_codec sdhci                  20676  1 sdhci_pci v4l2_compat_ioctl32    10736  1 videodev firewire_ohci          23348  0 i2c_nforce2            9048  0 amd64_edac_mod        29632  0 snd_timer              22608  2 snd_seq,snd_pcm i2c_core              28656  3 nvidia,videodev,i2c_nforce2 cfg80211              87800  2 b43,mac80211 firewire_core          47880  1 firewire_ohci edac_core              43516  1 amd64_edac_mod k8temp                  5344  0 joydev                11984  0 forcedeth              54764  0 snd                    67592  15 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer mmc_core              58832  1 sdhci rfkill                20488  1 cfg80211 soundcore              7328  1 snd snd_page_alloc          9568  2 snd_hda_intel,snd_pcm ricoh_mmc              4384  0 crc_itu_t              2080  1 firewire_core ssb                    43600  1 b43 wmi                    7280  0 ata_generic            5924  0 pata_acpi              5152  0 pata_amd              14260  0 video                  23476  0 output                  3360  1 video Adding to this I can't seem to find any acpi related errors in the dmesg output... I also found that using ubuntu (karmik) this doesn't happen, can it be a kernel problem? Any ideas to solve this? (HowTos)