5

Multiple gcc and linking between them

view full story
linux-howto

http://unix.stackexchange.com – I'm running centOS 6.3 which comes with gcc 4.4.6 and I installed gcc 4.6.3 using these instructions. But when I type gcc -v it still says gcc 4.4 is the version I'm using. The newer version is under /opt/gcc-4.6.3. When I run a make command do I have to specify a path to use the newer gcc? If so how do I do this, or can I replace the older version fully with the newer one? Thanks in advance. (HowTos)