6

mod_security - PCRE limits exceeded

view full story
linux-howto

http://serverfault.com – Just about on every request I am getting the following error: Rule execution error - PCRE limits exceeded (-8): (null). After a bunch of googling the only solutions seem to be a) Add the following in your httpd.conf SecPcreMatchLimit 150000 SecPcreMatchLimitRecursion 150000 b) Add the following to your php.ini pcre.backtrack_limit = 10000000 pcre.recursion_limit = 10000000 c) Use a version that was compiled with -disable-pcre-match-limit option. I am running the following: ModSecurity for Apache/2.5.12 (http://www.modsecurity.org/). Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze8 wit (HowTos)