3

LVM, first time, can't open from rescueCD

view full story
linux-howto

http://forums.opensuse.org – With 11.2 I let it do a default install using LVM+encrypted and all went smoothly. I haven't used LVM before. I've done normal encrypt -cryptsetup LUKS- before and could always boot a rescueCD, run appropriate commands and mount chosen device to do backups or whatever. I tried with this new LVM setup. I got the partition open but couldn't open any of the logical volumes. Typing 'lvm' at CLI shows a list of commands. I do 'lvm pvscan' and it shows correctly : pv /dev/mapper/system VG system lvm2 15GB I do 'lvm vgscan' shows: found volume group "system" using metadata type lvm2 I do 'lvm lvscan' shows: inactive /dev/system/home 8GB inherit inactive /dev/system/root 6GB inherit inactive /dev/system/swap 1GB inherit Now, I rebooted onto the Suse 11.2 LiveCD and did: 'cryptsetup luksOpen /dev/sda2 kik' this opened the partition as above BUT amazingly, going to look at /dev and /dev/mapper I saw that there was /dev/system and /dev/mapper/kik and /dev/mapper/system-home + system-root + system-swap. these did _not_ show up with rescueCD. I could then mount the root+home under /dev/system and look at the files, in effect the Logical Volumes. Typing 'lvm' at CLI this time changed the prompt to lvm>, and doing same commands 'pvscan' 'vgscan' 'lvscan' as above gave same output except for last which gave: active /dev/system/xxxx 8GB inherit for appropriate volumes. To sum up; openSuse magically gets the Logical Volumes out of encryption and onto /dev/mapper; my rescueCD and another 2.6.31.5-kernel distro can't. When I look at 'lsmod' in each, there's no difference for the various crypto modules and they all can use ext4. I don't see anything in 'mans' wrt luks or LVM about "opening" or mounting a Logical Volume from a Volume Group. How should I be able to do that and what step or such is missing using the other boot cds? (Distributions)