9

LibreOffice changes: dependencies, 'Fresh' branch & misguiding package names

view full story
linux-howto

http://archlinux.2023198.n4.nabble.com – Hi everybody, During a recent system upgrade I noticed I had a couple of new orphaned packages, among which libcdr, libetonyek, libmspub, libodfgen, libvisio and libwps. A quick investigation directed me to the libreoffice-common package, which has ceased relying upon them in its 4.2.4-2 version. PKGBUILD's message is "use internal file format libs because new library releases from system that depend on librenvenge are not supported by this LibO stable branch" [1]. Looking for packages that may depend on the orphaned libs made me discover libreoffice-fresh, the "LibreOffice bran (Distributions)