5

libcurl.4.dylib version on Mac

view full story
linux-howto

http://serverfault.com – I installed nginx on my Mac (Snow Leopard) but it looks like I messed up with libcurl in process. Now when I try to use git I'm getting this error: dyld: Library not loaded: /usr/lib/libcurl.4.dylib Referenced from: /usr/libexec/git-core/git-remote-https Reason: Incompatible library version: git-remote-https requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0 I downloaded and compiled the latest version of libcurl but it changed nothing. Additionally when I run otool -L /usr/local/lib/libcurl.4.dylib I'm getting: otool -L /usr/local/lib/libcurl.4.dylib /usr/local/ (HowTos)