6

libcrypto.so.10 dependency error when upgrading to VirtualBox 3.1

view full story
linux-howto

http://forums.fedoraforum.org – Hey everyone. I'm currently running VB 3.0.10 on Fedora 12 64 bit. # uname -a Linux enterprise 2.6.30.9-99.fc11.x86_64 #1 SMP Tue Nov 17 21:30:38 EST 2009 x86_64 x86_64 x86_64 GNU/Linux When I attempt to upgrade my current install to 3.1 I get the following: # rpm -U VirtualBox-3.1-3.1.0_55467_fedora12-1.x86_64.rpm warning: VirtualBox-3.1-3.1.0_55467_fedora12-1.x86_64.rpm: Header V4 DSA signature: NOKEY, key ID 6dfbcbae error: Failed dependencies: libcrypto.so.10()(64bit) is needed by VirtualBox-3.1-3.1.0_55467_fedora12-1.x86_64 I am somewhat puzzled as this is a upgrade from a stable installed version. I have confirmed I have libcrypto.so.8 . . . from what I can tell its part of the openssl package but I've got the most current so I don't know how to obtain the libcrypto.so.10 file to correct this issue. I am open to suggestions? (HowTos)