5

Libc6 MAJOR problem

view full story
linux-howto

http://www.linuxquestions.org – Hello, Recently I got an error to do with libc6 when trying to install ovd-session-manager , so I googled the error and went through a list of websites trying to solve the error. I tried loads of commands as root to try fix this error, but I have done something seriously wrong to libc instead of fixing anything... ssh will no longer work becuase of libc6, I have webmin installed and is my current only way of accessing my server. No commands will work, ssh is broke and nothing will install. Code: Now updating libc6 ..       Installing package(s) with command apt-get -y install libc6 ..       dpkg: dependency problems prevent configuration of libpam0g:       libpam0g depends on libc6 (>= 2.8~20080505); however:         Version of libc6 on system is 2.3.6.ds1-13etch7.       dpkg: error processing libpam0g (--configure):       dependency problems - leaving unconfigured       dpkg: dependency problems prevent configuration of libpam-modules:       libpam-modules depends on libc6 (>= 2.8~20080505); however:         Version of libc6 on system is 2.3.6.ds1-13etch7.       libpam-modules depends on libdb4.7; however:         Package libdb4.7 is not installed.       libpam-modules depends on libpam0g (>= 0.99.7.1); however:         Package libpam0g is not configured yet.       libpam-modules depends on libselinux1 (>= 2.0.59); however:         Version of libselinux1 on system is 1.32-3.       dpkg: error processing libpam-modules (--configure):       dependency problems - leaving unconfigured       Setting up libpam-runtime (1.0.1-4ubuntu5.6) ...       Undefined subroutine &main::x_loadtemplatefile called at /usr/sbin/pam-auth-update line 100.       dpkg: error processing libpam-runtime (--configure):       subprocess post-installation script returned error exit status 9       Errors were encountered while processing:       libpam0g       libpam-modules       libpam-runtime       Reading package lists...       Building dependency tree...       You might want to run `apt-get -f install' to correct these:       The following packages have unmet dependencies:         libc6: Depends: findutils (>= 4.4.0-2ubuntu2) but 4.2.28-1etch1 is to be installed               Conflicts: tzdata-etch         libc6-i686: PreDepends: libc6 (= 2.3.6.ds1-13etch7) but 2.8~20080505-0ubuntu9 is to be installed         libpam-modules: Depends: libdb4.7 but it is not going to be installed                         Depends: libselinux1 (>= 2.0.59) but 1.32-3 is to be installed         locales: Depends: glibc-2.3.6.ds1-1       E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). I get this error for installing Libc, and its very similar on installing any other packages. Im not 100% sure what I have done... Heres error for trying to install something random: Code: Installing package(s) with command apt-get -y install ftp .. dpkg: dependency problems prevent configuration of libpam0g:  libpam0g depends on libc6 (>= 2.8~20080505); however:   Version of libc6 on system is 2.3.6.ds1-13etch7. dpkg: error processing libpam0g (--configure):  dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libpam-modules:  libpam-modules depends on libc6 (>= 2.8~20080505); however:   Version of libc6 on system is 2.3.6.ds1-13etch7.  libpam-modules depends on libdb4.7; however:   Package libdb4.7 is not installed.  libpam-modules depends on libpam0g (>= 0.99.7.1); however:   Package libpam0g is not configured yet.  libpam-modules depends on libselinux1 (>= 2.0.59); however:   Version of libselinux1 on system is 1.32-3. dpkg: error processing libpam-modules (--configure):  dependency problems - leaving unconfigured Setting up libpam-runtime (1.0.1-4ubuntu5.6) ... Undefined subroutine &main::x_loadtemplatefile called at /usr/sbin/pam-auth-update line 100. dpkg: error processing libpam-runtime (--configure):  subprocess post-installation script returned error exit status 9 Errors were encountered while processing:  libpam0g  libpam-modules  libpam-runtime Reading package lists... Building dependency tree... You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies:   ftp: Depends: libc6 (>= 2.4) but 2.3.6.ds1-13etch7 is to be installed       Depends: libncurses5 (>= 5.6+20071006-3) but 5.5-5 is to be installed   libpam-modules: Depends: libc6 (>= 2.8~20080505) but 2.3.6.ds1-13etch7 is to be installed                   Depends: libdb4.7 but it is not going to be installed                   Depends: libselinux1 (>= 2.0.59) but 1.32-3 is to be installed   libpam0g: Depends: libc6 (>= 2.8~20080505) but 2.3.6.ds1-13etch7 is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). And its like that for any apt-get install. Heres error for starting ssh server Code: > /etc/init.d/ssh start su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libpam.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by /lib/libpam.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libpam_misc.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by /lib/libpam_misc.so.0) And apt-get install GLIBC_2.4 Code: > apt-get GLIBC_2.4 su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libpam.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by /lib/libpam.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libpam_misc.so.0) su: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.8' not found (required by /lib/libpam_misc.so.0) I have no idea what command I have done to mess libc up, and have no idea how to fix it. Could somebody please help? Or maybe post some ideas on what I have done please? Thanks, Chris. (HowTos)