3

[kubuntu] Kubuntu Intrepid Graphics Issues

view full story
linux-howto

http://ubuntuforums.org – Okay, so I'm attempting to install Kubuntu Intrepid Ibex on an old-ish desktop computer with fairly decent specs. The really decent part about the machine is its ATI Radeon 9500 graphics card. I cannot for the life of me get the graphics to work. Searched it on Google and got that there was a major problem with ATI graphics for a while on Intrepid, that for a while there was no graphics driver from them, and then the graphics driver was flawed and wouldn't work with 8.10 I thought the issue was corrected, though. I'm trying with all my might to get this stupid card to function the right way, but all I get back is crap from it. The copy of Kubuntu was originally installed with a much weaker AGP graphics card, an older nVIDIA with only 64MB of memory. Now that I'm trying to replace it, the machine is acting up on me. On the graphics drivers for XOrg installed through Adept, I get a command line login and then after it, I cannot start X manually through "sudo startx". I get a few errors and then it returns me to the command line. I reinstalled the old card and purged the drivers. I installed all the recent updates and then the drivers again. Still no luck. Purged the drivers again, turned to ATI and installed their Catalyst 9.3 drivers with these instructions (adapting them for the proper version of the drivers). When I restarted the computer, though...well, let's just leave it at "it wasn't pretty" (what I mean by that is that there were colored lines on the bottom half of the monitor and the top half was like the Kubuntu loading screen but there were two of them and they were totally off-color; I waited a while and it didn't change). To make sure the chip still worked, I used a live copy of Kubuntu Karmic on a CD. Yep, perfect working condition. Nothing at all out of the ordinary. The problem is that I want to install the new beta of LinuxMCE on top of Intrepid after I take care of this problem. And I can't do that unless I'm using Intrepid. I have a PNY Verto GeForce 5200 waiting on standby in case I need it, but it's probably not nearly as good as this ATI Radeon is. Any help at all would be appreciated. Thanks in advance! (Hardware)