2

[kubuntu] Gpen F610 installation issue

view story
linux-howto

http://ubuntuforums.org – Hi Folks, Kubuntu 64 bit 9.10. Plugged the tablet in and the mouse responded but nothing to the buttons. Gimp had a Wacom tablet listed but wouldn't listen to anything on it. Followed a couple of tutorials, https://help.ubuntu.com/community/TabletSetupWizardpen and http://digitalbluewave.blogspot.com/...epid-ibex.html ...and now I've got nothing in Gimp and even the cursor doesn't want to listen. However while... ./wizardpen-calibrate /dev/input/event6 ...gives a permissions error ... sudo ./wizardpen-calibrate /dev/input/event6 ...allows me to calibrate. So... first off, I may be looking at a permissions issue. /dev is rwxr-xr-x root root /dev/input is rwxr-xr-x root root /dev/input/event6 is rwxr----- root root ... so is this a permissions issue, or is some administration process not configured properly? To assist troubleshooting on that score... I tried wizardpen 0.6.0.2 and had to force it to install as it is 32 bit. Then I tried wizardpen 0.7.0-alpha2 - again forced install. Code: $ grep -i name /proc/bus/input/devices N: Name="Power Button" N: Name="Power Button" N: Name="Macintosh mouse button emulation" N: Name="AT Translated Set 2 keyboard" N: Name="Cypress Sem PS2/USB Browser Combo Mouse" N: Name="Microsoft SideWinder Game Voice" N: Name="WALTOP International Corp. Slim Tablet" N: Name="HDA Digital PCBeep" I put the calibration figures in to this file... Code: cat /etc/hal/fdi/policy/99-x11-wizardpen.fdi <?xml version="1.0" encoding="ISO-8859-1" ?>  <deviceinfo version="0.2">  <device>  <!-- This MUST match with the name of your tablet -->  <match key="info.product" contains="WALTOP International Corp. Slim Tablet">  <merge key="input.x11_driver" type="string">wizardpen</merge>  <merge key="input.x11_options.Device" type="string">/dev/input/event6</merge>  <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>  <merge key="input.x11_options.TopX" type="string">373</merge>  <merge key="input.x11_options.TopY" type="string">347</merge>  <merge key="input.x11_options.BottomX" type="string">20000</merge>  <merge key="input.x11_options.BottomY" type="string">12500</merge>  <merge key="input.x11_options.MaxX" type="string">20000</merge>  <merge key="input.x11_options.MaxY" type="string">12500</merge>  </match>  </device> </deviceinfo> However a different name shows up in... Code: $ cat /sys/bus/usb/devices/*/product SideWinder Game Voice Slim Tablet PS2/USB Browser Combo Mouse EHCI Host Controller EHCI Host Controller OHCI Host Controller OHCI Host Controller OHCI Host Controller OHCI Host Controller OHCI Host Controller ..and I may have done myself no favours following the other instructions which has got me... Code: $ cat /etc/udev/rules.d/010_local.rules BUS=="usb", KERNEL=="event*", SYSFS{product}=="WALTOP International Corp. Slim Tablet", NAME="input/%k", SYMLINK+="tablet-event", MODE="0666" ...which may or may not be interfearing ... I don't know. However ... I did notice this in /var/log/Xorg.0.log... Code: (II) config/hal: Adding input device WALTOP International Corp. Slim Tablet (II) LoadModule: "wizardpen" (II) Loading /usr/lib/xorg/modules/input//wizardpen_drv.so dlopen: /usr/lib/xorg/modules/input//wizardpen_drv.so: wrong ELF class: ELFCLASS32 (EE) Failed to load /usr/lib/xorg/modules/input//wizardpen_drv.so (II) UnloadModule: "wizardpen" (EE) Failed to load module "wizardpen" (loader failed, 7) (EE) No input driver matching `wizardpen' ...and I'm pretty sure the // shouldn't be in there. However I don't know what file that entry is in so I don't know where to go to put the right slashes in. (it isn't in xorg.conf) Anyone help please? (Hardware)