6

kdm user / passwd prompt missing

view full story
linux-howto

http://forums.opensuse.org – I am no longer required to enter my password to log in to my user account. How can I get it back? I have made no conscious change to this effect. I first noticed this after installing and using the debug kernel to get my Broadcom wifi chipset recognized. (The default kernel does not recognize the chipset but the debug kernel does.) /boot/vmlinuz-2.6.31.12-0.1-default /boot/vmlinuz-2.6.31.12-0.1-debug <-- /vmlinuz I'm essentially "new" to SuSE but not to Linux distros (Debian, &c. mostly). I have openSUSE 11.2 installed from LiveCD. I'm running KDE4 as installed. grub-legacy is managing my boot as installed but with a modified (by YaST2 and by me) menu.lst file. I have also enabled and disabled some repositories. I won't post my zypper lr -d unless requested as this is already a long first post. While I am not required to use a password to login, the user password is required to unlock the screen saver and the root password is required for both graphical and text root privileges (e.g. YaST2 and sudo). I have changed both the user and root passwords (from CLI) and they are now unique. Changing the user password and rebooting proved to me that it was not "remembering" my password somehow (unless I've been cracked -- which I kinda doubt but don't rule out entirely). I have perused the forum for this problem and found information on how to make my login not require a password. When I go to those places it would appear my password is still required. No hurry, just testing different distros on old hardware and trying to learn new things. Confession: I've used SuSE 6.3 years ago and used RedHat and slackware before that, but I've been using Debian and derivatives for the past several years in my spare time. I use XP for work on their dime. Mostly Linux and Mac at the house, though. (Distributions)