7

Installation issue with MySQL-server-5.1.43-1.rhel5.ia64 [libirc.so(64bit) is needed]

view full story
linux-howto

http://www.linuxquestions.org – Hi Folks, I've got HP RX2660 Itanium-64bit Architecture machine on which I installed REHL 5.0 for IA-64 with Kernel [kernel-2.6.18-164.el5]. I downloaded the following MYSQL Packages for MY SQL installation --> MySQL-client-community-5.1.43-1.rhel5.ia64.rpm --> MySQL-community-debuginfo-5.1.43-1.rhel5.ia64.rpm --> MySQL-server-community-5.1.43-1.rhel5.ia64.rpm But when I try to install MY-SQL Server it produce the following error. # rpm -i MySQL-server-community-5.1.43-1.rhel5.ia64.rpm error: Failed dependencies: libirc.so()(64bit) is needed by MySQL-server-community-5.1.43-1.rhel5.ia64 I searched for this dependency and found that it requires Intel C++ libraries to be installed on the machine. Then I downloaded the following RPM and TAR Zipped packages for REHL5.0-Ia-64 from My SQL OS download area for installation. --> intel-icc9-libs-9.0-025.ia64.rpm --> intel-icc9-libs-9.0-ia64.tar.gz But now when I try to install these it presents the following error. # rpm -i intel-icc9-libs-9.0-025.ia64.rpm warning: intel-icc9-libs-9.0-025.ia64.rpm: Header V3 DSA signature: NOKEY, key ID 5072e1f5 file /usr/lib/libunwind.a from install of intel-icc9-libs-9.0-025.ia64 conflicts with file from package libunwind-0.98.5-5.el5.ia64 file /usr/lib/libunwind.so from install of intel-icc9-libs-9.0-025.ia64 conflicts with file from package libunwind-0.98.5-5.el5.ia64 Kindly help me to overcome these issues. I have also taken following steps to resolve the situation but failed. 1: extracted all the libraries from intel-icc9-libs-9.0-ia64.tar.gz and copied them in /lib and /usr/lib folders (although libirc.so file was not present in these) 2: downloaded Intel professional C++ compiler evaluation edition from intel website and installed via recommeded way. 3: Copied libirc.so file from x86 package to /lib and /usr/lib folder 4: tried to install the previous release intel-icc8-libs-8.1-0.ia64.rpm but the same error [conflicts with file from package libunwind-0.98.5-5.el5.ia64] is produced. Best Regards, Bilal (HowTos)