5

How to install older version of glibc?

view full story
linux-howto

http://unix.stackexchange.com – I'm trying to install gcc-4.4 on RHEL6: sudo rpm -ivh /mnt/dvd/Packages/gcc-4.4.3-1.el6.x86_64.rpm. But the problem is that is depends on glibc and glibc-common libraries. When I try to install them using command sudo rpm -ivh /mnt/dvd/Packages/glibc-common-2.11.1-1.10.el6.x86_64.rpm /mnt/dvd/Packages/glibc-2.11.1-1.10.el6.x86_64.rpm, I get following error: file *.so from install of glibc-2.11.1-1.10.el6.x86_64 conflicts with file from package glibc-2.12-1.7.el6.x86_64 How could I make glibc 2.11 installed instead of 2.12? Is there any other way to install gcc without downgrading to glibc 2.1 (HowTos)