1

gecko-libs dependency error in yum

view story
linux-howto

http://forums.fedoraforum.org – Last night I was updating my system and I ran into some dependency errors. It seems like gecko-libs is having problems. here are my yum update results. Code: Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package epiphany.i586 0:2.26.3-1.fc11 set to be updated ---> Package firefox.i586 0:3.5.1-1.fc11 set to be updated --> Processing Dependency: gecko-libs = 1.9.1 for package: epiphany-2.26.3-1.fc11.i586 ---> Package xulrunner.i586 0:1.9.1.1-1.fc11 set to be updated ---> Package yelp.i586 0:2.26.0-5.fc11 set to be updated --> Finished Dependency Resolution epiphany-2.26.3-1.fc11.i586 from updates has depsolving problems   --> Missing Dependency: gecko-libs = 1.9.1 is needed by package epiphany-2.26.3-1.fc11.i586 (updates) Error: Missing Dependency: gecko-libs = 1.9.1 is needed by package epiphany-2.26.3-1.fc11.i586 (updates)  You could try using --skip-broken to work around the problem  You could try running: package-cleanup --problems                         package-cleanup --dupes                         rpm -Va --nofiles --nodigest Code: sudo rpm -qa|grep yum yum-3.2.23-3.fc11.noarch yum-metadata-parser-1.1.2-12.fc11.i586 anaconda-yum-plugins-1.0-4.fc11.noarch yum-utils-1.1.22-1.fc11.noarch PackageKit-yum-0.4.8-2.fc11.i586 PackageKit-yum-plugin-0.4.8-2.fc11.i586 yumex-2.0.5-6.fc11.noarch is anybody having this issue? could someone please help, thanks.:D (HowTos)