5

Fedora 11 X very slow

view full story
linux-howto

http://forums.fedoraforum.org – Hi, I know there's a few similar threads, and there seem to be some issues with old ATI cards (which is what I have) but I've tried as many of the proposed solutions that I can find/understand, and I'm still no closer to resolving my problem. I'm trying to use Fedora 11 on a Fujitsu P2110 (800MHz Crusoe) with 512mb RAM and an ATI Rage Mobility-M1. X (Gnome or XFCE) is slow enough to be pretty much unusable, though it does work eventually. A lot of threads suggest this could be an ATI problem, so I've tried various drivers (either with system-config-display or by editing xorg.conf) - mach64, ati, vesa, but none make a difference. It takes nearly three minutes for the desktop to be complete after logging in, during which time CPU usage is high, though there's no one process hogging the CPU, just a lot of processes all using 5-6% each as far as I can tell from top. Once the desktop is there, opening Firefox takes nearly two minutes, during which time top shows very high CPU usage but only shows Firefox (at the top of the list) using a few %. Assuming it was an ATI problem, I've tried Code: Option "MigrationHeuristic" "greedy" as suggested in several places, but to no avail. Code: Option "AccelMethod" "EXA" results in the console going blank, as if it's about go into X, only to return a few seconds later and repeating (the log shows "Caught signal 11. Server aborting"). So I'm left wondering whether it really is the graphics card at all. As you can probably tell I'm not used to using Fedora with X, though I've used it for years without it as a server, which is why I'm persevering with it now. I'd really appreciate any pointers or hints as to what else I can do to trace this problem. Thanks, David (HowTos)