6

FC12: cannot start X-application remotely using VNC desktop access

view full story
linux-howto

http://forums.fedoraforum.org – Hello, I have problem with gnome desktop accessed via VNC. The package vncserver package was installed. SElinux is on. No customization to std. FC12 selinux policy (3.6.32-66) (BTW. even SELINUX is OFF behaviour is the same). Server configuration: /etc/sysconfig/vncserversVNCSERVERS="1:edx" VNCSERVERARGS[1]="-geometry 1024x768 -nolisten tcp -localhost" ~/.vnc/xstartup#!/bin/sh unset SESSION_MANAGER exec /etc/X11/xinit/xinitrc [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources xsetroot -solid grey vncconfig -iconic & The user 'edx' password was defined. vncserver service is up. I am accessing the desktop from remote tightVNC via ssh tunnel. I see the desktop. I can run applets from administration panel, but I cannot start other applications, e.g. Firefox. The icon showing that application is starting is visible over few seconds and this is all ! The ~/.vnc/host:1.log file shows the following: [... cut ...] (polkit-gnome-authentication-agent-1:2440): polkit-gnome-1-WARNING **: Unable to determine the session we are in: Remote Exception invoking org.freedesktop.ConsoleKit.Manager.GetSessionForUn ixProcess() on /org/freedesktop/ConsoleKit/Manager at name org.freedesktop.ConsoleKit: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. Xlib: extension "DPMS" missing on display ":1.0". ** (gnome-volume-control-applet:2521): WARNING **: Connection failed, reconnecting... E: main.c: Start failed. ** (gnome-settings-daemon:2293): WARNING **: Connection failed, reconnecting... ** (gnome-panel:2313): WARNING **: Could not ask session manager if shut down is available: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. ** (gnome-settings-daemon:2293): WARNING **: Connection failed, reconnecting... ** (gnome-screensaver:2342): WARNING **: Couldn't get presence status: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken. ** (gnome-volume-control-applet:2521): WARNING **: Connection failed, reconnecting... ** (gnome-settings-daemon:2293): WARNING **: Connection failed, reconnecting... ** (gnome-volume-control-applet:2521): WARNING **: Connection failed, reconnecting... (firefox:2665): GLib-WARNING **: g_set_prgname() called multiple times ** (gnome-settings-daemon:2293): WARNING **: Connection failed, reconnecting... ** (gnome-settings-daemon:2293): WARNING **: Connection failed, reconnecting... ** (gnome-volume-control-applet:2521): WARNING **: Connection failed, reconnecting... ^C Any hints what should be done to fix the problem? Thanks, Edward (HowTos)