4

F12 - Problem with Line-In on Intel HDA on-board sound

view full story
linux-howto

http://forums.fedoraforum.org – I recently built a new system using an ASUS P6T Deluxe V2 motherboard that has Intel HD Audio on-board. Sound from my computer worked just fine immediately after installing Fedora 12. There is a problem though. I route my Xbox 360's audio output into my computer via the line-in jack, but I get no sound output. In the sound preferences, I set the Input to Line-In, and I can see the Input Level fluctuating... so I know that the sound is getting through, but no matter what volume settings I use in Gnome, I don't hear anything. I did some searching around, and found other people with similar problems with the new Gnome sound prefs not providing enough controls... and the general answer was to use 'alsamixer -c0' to unmute the line-in volume. This worked perfectly, and I could hear sound from my video games... but now I couldn't get sound from programs on my computer. Audacious and mpg321 both freeze solid until I kill the task, and Totem refuses to play anything with audio (but at least the GUI responds). My guess is that using alsamixer confuses pulseaudio in some manner. I tried restarting pulseaudio, but that didn't work either (it doesn't seem to "see" my sound hardware after restart, as nothing shows up in the Hardware tab of Sound Preferences, though alsamixer still works, and line-in gets through). Rebooting gets me back to square one, with line-in still muted. Does anyone know the answer to this riddle? (HowTos)