0

Evolution-2.28 build failure on Fedora 10

view story
linux-howto

Hi, I was trying to build evolution 2.28 on fedora 10. The errors I'm getting are checking for GNOME_PLATFORM... configure: error: Package requirements (glib-2.0 >= 2.20.0 gtk+-2.0 >= 2.16.0 gconf-2.0 >= 2.0.0 libbonobo-2.0 >= 2.20.3 libbonoboui-2.0 >= 2.4.2 libglade-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libgnomeui-2.0 >= 2.0.0 libxml-2.0 >= 2.7.3 shared-mime-info >= 0.22 gnome-desktop-2.0 >= 2.26.0) were not met: Requested 'glib-2.0 >= 2.20.0' but version of GLib is 2.18.2 Requested 'gtk+-2.0 >= 2.16.0' but version of GTK+ is 2.14.4 Requested 'libxml-2.0 >= 2.7.3' but version of libXML is 2.7.2 Requested 'gnome-desktop-2.0 >= 2.26.0' but version of gnome-desktop-2.0 is 2.24.3 Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables GNOME_PLATFORM_CFLAGS and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. error: Bad exit status from /var/tmp/rpm-tmp.l7VLcj (%build) RPM build errors: Bad exit status from /var/tmp/rpm-tmp.l7VLcj (%build) To resolve the above errors, I changed the versions of the dependencies for the packages in configure file in the tar ball of evolution-2.28 (which I realised as not a correct step after I got the same build errors). I'm unable to find GNOME_PLATFORM_CFLAGS & GNOME_PLATFORM_LIBS, from where I believe the configure script is taking the dependency package versions . Would someone please guide me, on how to resolve these dependencies and build the evolution package?. Regards Dheeraj G ()