6

DVD-rom not auto-mounting/reading discs in Fedora 10

view full story
linux-howto

http://forums.fedoraforum.org – I'm not sure when the problem started exactly, but up until today my computer would detect and mount anything I put in my DVD-rom drive. But, I noticed that it no longer even attempts to read anything I put in it. It won't even read a XP installation boot disc upon being restarted. The drive's light flashes, and I hear the drive attempting to read the disc (it makes the typical grinding and whirling noises) but nothing happens and after a few minutes the light stops flashing. It does this on any CD (data, burned, audio), and I can read the discs just find on my WinXP lappy. The drive is detected in my BIOS, but appears to have vanished from fstab and mtab. I tried using the Mount command to manually mount it, but I get a message back saying that there is no medium detected. I unplugged the drive from the machine and plugged it back in, and still nothing. Below are the relevant information I could pull from dmesg, which is basically anything that references my DVD drive: ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300) ata2.00: ATAPI: TSSTcorp CDDVDW TS-H653N, HB02, max UDMA/100 ata2.00: configured for UDMA/100 [...] scsi 1:0:0:0: CD-ROM TSSTcorp CDDVDW TS-H653N HB02 PQ: 0 ANSI: 5 sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray Uniform CD-ROM driver Revision: 3.20 sr 1:0:0:0: Attached scsi CD-ROM sr0 sr 1:0:0:0: Attached scsi generic sg1 type 5 My question is, is this a hardware failure or did something somehow get screwed up in my installation? Edit: My installation can still detect and automount a memory stick. (HowTos)