2

Display Corruption when migrating from FC9 to FC11

view story
linux-howto

http://forums.fedoraforum.org – System: http://www.smolts.org/client/show/?u...7-667b060f34e6 Notably Dell Dimension 2400 w/ 845G graphics chipset and e207wfp Dell LCD display. Problem: Updating from FC9 to FC11. Display worked fine in FC9 at a lower resolution, but forgot which tweaks I did to make it so. Now display works OK even at a higher-resolution (with xrandr -s 1680x1050 in my .bashrc) except for a couple of cases. However, corruptions occur in all resolutions. The display sometimes becomes corrupt when certain programs run. Most notably when any video is played with mplayer, facebook, or youtube and most graphic program fStop, etc, but less noticeable when excel (using codeweavers wine) runs. It might be of interest when viewing .jpg files with gwenview there is no corruption. Also all instances of Flash displaying causes corruption of display whether in a browser or stand alone with gnash. However, GL looks like it works (glxgears works fine) and mplayer -vo gl works also with all videos, but pretty slow. See screen captures, xorg.conf, and Xorg.0.log. Tried: As per suggestions from others and the sticky post here I have done the following: Made sure that there are no graphics drivers being overwritten or residual drivers by doing a: rpm -Va with no apparent discrepancies. Disabled DRI in the xorg.conf with no apparent change with corruption. Determined the Modeline for my display and put it in xorg.conf with no change. Checked all rpms for fc9 and either updated to fc11 or removed them and resolved resulting inconsistencies. Searched the forum for such like problems. A lot of problems with this display but none that fit mine. xrand --verbose gives: Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096 VGA1 connected 1680x1050+0+0 (0x3b) normal (normal left inverted right x axis y axis) 430mm x 270mm Identifier: 0x3a Timestamp: 89272 Subpixel: unknown Clones: CRTC: 0 CRTCs: 0 Transform: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000 filter: 1680x1050 (0x3b) 146.2MHz -HSync +VSync *current +preferred h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.3KHz v: height 1050 start 1053 end 1059 total 1089 clock 60.0Hz 1024x768 (0x3c) 65.0MHz -HSync -VSync h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz v: height 768 start 771 end 777 total 806 clock 60.0Hz 800x600 (0x3d) 40.0MHz +HSync +VSync h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz v: height 600 start 601 end 605 total 628 clock 60.3Hz 640x480 (0x3e) 25.2MHz -HSync -VSync h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz v: height 480 start 490 end 492 total 525 clock 60.0Hz Suggestions? Any would be appreciated. Thanks, Glen Attached Images gnashCorruption.jpg (57.6 KB) gThumbCorruption.jpg (77.4 KB) excelCorruption.jpg (62.6 KB) Attached Files Xorg.0.log.txt (169.7 KB) xorg.conf (1.0 KB) (HowTos)