6

Configuring dual head graphics card for dual monitors

view full story
linux-howto

http://www.linuxforums.org – I'm running Ultimate Edition 2.3, which is based off of Ubuntu 8.04. I have a dual monitor system that I'm running off of my dual head GeForce FX 5200 graphics card. So far, I have installed the 173 driver and got it so I have two independent monitors. However, I've come to an issue that I'm not sure of how to fix. As I said, I have two independent monitors, however, whenever I open a folder or program on the right monitor, the folder/program actually opens on the left monitor. Now, the mouse moves across both monitors just fine, and because they act independent, I can't drag a window across both monitors. But, I just don't understand how they're independent, yet whatever I do on the right monitor, the results appear on the left monitor. Anyone have a solution to this? Here is what my xorg.conf file currently looks like. I added a few lines to the xorg file myself. I really don't think my adds did anything bad, but I'll point them out anyways. Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 Screen 1 "Screen1" RightOf "Screen0" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection Section "Module" Load "dbe" Load "extmod" Load "type1" Load "freetype" Load "glx" EndSection Section "ServerFlags" Option "Xinerama" "0" EndSection Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "HSD Hanns.G HW173" HorizSync 24.0 - 71.0 VertRefresh 55.0 - 75.0 Option "DPMS" EndSection Section "Monitor" Identifier "Monitor1" VendorName "Unknown" ModelName "HSD Hanns.G HW173" HorizSync 24.0 - 71.0 VertRefresh 55.0 - 75.0 Option "DPMS" <--added this line EndSection Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce FX 5200" BusID "PCI:1:0:0" Screen 0 EndSection Section "Device" Identifier "Device1" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce FX 5200" BusID "PCI:1:0:0" Screen 1 EndSection Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "TwinView" "0" Option "TwinViewXineramaInfoOrder" "CRT-0" Option "metamodes" "CRT-0: 1152x864 +0+0" SubSection "Display" Depth 24 EndSubSection EndSection Section "Screen" Identifier "Screen1" Device "Device1" Monitor "Monitor1" DefaultDepth 24 Option "TwinView" "0" Option "TwinViewXineramaInfoOrder" "CRT-1" <--added this line Option "metamodes" "CRT-1: 1152x864 +0+0" <--edited this line...was originally set to auto..I specific the resolution SubSection "Display" Depth 24 EndSubSection EndSection (HowTos)