1

Compiling PHP on Solaris

view story
linux-howto

http://serverfault.com – I'm compiling PHP with --enable-fpm on Solaris 10 (sun4v sparc SUNW,Sun-Fire-T1000) and it stops at #error Sparc v8 and predecessors are not and will not be supported (see bug report 53310) Following the error, the CPU I have is a v9 ? Why is the error occurring? How should the compilation be signaled to include a -mcpu=v9 ? Would that help? Edit: I've tried compiling both 5.3.8 and the latest 5.4.7 - and the error appears for both. PHP and PHP-CGI compiles fine. (HowTos)