Can't install httpd-devel on CentOS 6

view story

http://unix.stackexchange.com – using CentOS 6.3 x86_64 and Apache/2.2.15 I get the following error running "yum install httpd-devel.x86_64" Error: Package: glibc-2.12-1.80.el6.i686 (base): Requires: glibc-common = 2.12-1.80.el6 Installed: glibc-common-2.12-1.80.el6_3.3.x86_64 (@updates) glibc-common = 2.12-1.80.el6_3.3 Available: glibc-common-2.12-1.80.el6.x86_64 (base) glibc-common = 2.12-1.80.el6` with "yum install httpd-devel.x86_64 --skip-broken", I get: Packages skipped because of dependency problems: > apr-1.3.9-3.el6_1.2.i686 from base apr-devel-1.3.9-3.el6_1.2.x86_64 > from base ap (HowTos)