6

Can't connect Ralink 2561 wlan - please help

view full story
linux-howto

http://forums.opensuse.org – Hi everyone, I have installed opensuse 11.2 on a second partition, with the ultimate aim of leaving windows altogether. Unfortunately, I seem to be having terrible trouble (as do many others) getting my wireless internet connection working. I have viewed lots of posts in these forums and done everything I can think of, but since I am a linux novice, am unable to identify the problem. The card is working, since it can identify local SSIDs, it has been set up (to the best of my knowledge) correctly in YAST, but nothing seems to work. Any help would be really appreciated! I'll include some information I have recorded from my system.. I typed the commands below with the accompanying output listed: sudo /usr/sbin/iwlist scan: Cell 04 - Address: my router's mac address Channel:13 Frequency:2.472 GHz (Channel 13) Quality=50/70 Signal level=-60 dBm Encryption key: on ESSID:"my ssid" Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s 24 Mb/s; 36 Mb/s; 54 Mb/s Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s Mode:Master Extra:tsf=000000c3b282c183 Extra: Last beacon: 273ms ago IE: Unknown: 000B70657465726C617572656E IE: Unknown: 010882848B962430486C IE: Unknown: 03010D IE: Unknown: 2A0104 IE: Unknown: 2F0104 IE: Unknown: 32040C121860 IE: Unknown: DD090010180203F0000000 IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00 /usr/sbin/iwconfig: wlan0 IEEE 802.11bg ESSID:"my ssid" Mode:Managed Frequency:2.472 GHz Access Point: my router's mac address Bit Rate=36 Mb/s Tx-Power=6 dBm Retry long limit:7 RTS thr: off Fragment thr: off Power Management: on Link Quality=46/70 Signal level=-64 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 /usr/sbin/iwconfig: wlan0 IEEE 802.11bg ESSID:"my ssid" Mode:Managed Frequency:2.472 GHz Access Point: my router's mac address Bit Rate=36 Mb/s Tx-Power=6 dBm Retry long limit:7 RTS thr: off Fragment thr: off Power Management: on Link Quality=46/70 Signal level=-64 dBm Rx invalid nwid: 0 Rx invalid crypt: 0 Rx invalid frag:0 Tx excessive retries: 0 Invalid misc: 0 Missed beacon:0 /sbin/ifconfig: wlan0 Link encap:Ethernet HWaddr my wlan card's mac address inet6 addr: fe80::20e:2eff:fe9d:6783/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:80 errors:0 dropped:0 overruns:0 frame:0 TX packets:87 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:4782 (4.6 Kb) TX bytes:29910 (29.2 Kb) netstat: Active Internet connections (w/o servers) Proto Recv-Q Send-Q Local Address Foreign Address State /sbin/lspci: - relevant line 02:07.0 Network controller: RaLink RT2561/RT61 802.11g PCI /sbin/lspci -n -relevant line 02:07.0 0280: 1814:0301 dmesg | grep wlan: [ 85.315444] ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 187.069746] ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 187.071108] wlan0: direct probe to AP my router's mac address try 1 [ 187.073298] wlan0: direct probe to AP my router's mac address try 1 [ 187.078916] wlan0 direct probe responded [ 187.078924] wlan0: authenticate with AP 00:1f:33:46:64:d0 [ 187.081826] wlan0: authenticated [ 187.081834] wlan0: associate with AP my router's mac address [ 187.084251] wlan0: RX AssocResp from my router's mac address (capab=0x411 status=0 aid=2) [ 187.084256] wlan0: associated [ 187.085047] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready [ 197.273023] wlan0: no IPv6 routers present dmesg | grep firmware: [ 85.285473] rt61pci 0000:02:07.0: firmware: requesting rt2561s.bin (Distributions)