3

Can I upgrade my graphics driver to support the latest OpenGL versions?

view full story
linux-howto

http://askubuntu.com – My laptop is a Core 2 Duo Dell from 2008. I am trying to run some OpenGL programs. The program with following code doesn't work: glutInitContextVersion(4, 0); glutInitContextFlags(GLUT_FORWARD_COMPATIBLE); glutInitContextProfile(GLUT_CORE_PROFILE); The code requires OpenGL version of 4.0. glxinfo suggests OpenGL version 2.1. The details of my Intel graphics driver from System Settings are: I don't see anything useful in the additional drivers section, except one Broadcom driver already activated. From Ubuntu Software Centre, I tried searching some other drivers and found Nvidia '173 (HowTos)